NYU Returns: Winter Break Closings & January Term Updates.
Incident Report for Public
Resolved
This incident has been resolved.
Posted Jan 03, 2022 - 23:55 EST
Monitoring

NYU Returns: Winter Break Closings & January Term Updates


Winter Break Access: December 23, 2021–January 2, 2022

  • NYU Libraries buildings will have limited hours and access for NYU students, faculty and staff only during winter break.
  • Locker Delivery pickups will be available when the buildings are open.
  • Refer to the hours page for the most up to date information.
  • Library services are closed.


January Term Updates: January 3, 2022 - January 23, 2022


In response to the University's updated safety protocols the Libraries has changed some services through January Term.
  • Buildings will reopen on January 3, 2022
    • Jack Brause and Courant libraries are closed
  • Building access is limited to NYU students, faculty, and staff. No visitor access for January Term.
  • January 4, 2022 remote library services resume. Services will be remote through January Term.

  • Please visit our the Libraries' NYU Returns page for details.


    Wishing you all a restful break and a happy new year!




    #nyureturns
Posted Dec 22, 2021 - 22:03 EST