Change to Services and Hours: End of Term and Winter Break.
Incident Report for Public
Resolved
This incident has been resolved.
Posted Jan 07, 2021 - 14:24 EST
Identified

NYU Returns: End of Term & Winter Break Closing Details, Fall 2020


Request Services Will Be Paused During Winter Break (starting the afternoon (ET) of Dec. 21)
Requests for scans or physical items submitted over the break will not be processed until January 5, 2021.



Adjusted Building & Service Schedules for New York Locations, Dec. 21, 2020 to Jan. 4, 2021


Bobst Library adjusted schedule
Brause Library is closed to users
Courant Library is closed to users
Dibner Library adjusted schedule
Institute of Fine Arts (IFA) adjusted schedule
Institute for the Study of the Ancient World (ISAW) adjusted schedule

Important Dates for Requesting Library Materials


Requests placed by 5:00 PM on December 18, we’ll do our best to process these before the winter break begins.

Requests placed after 5:00 PM on December 18, will be processed in order to be received when the library reopens on January 4.

For locker delivery, please plan to retrieve items by December 23.

Scan requests will be delivered by December 23.

Home delivery may take longer than usual during this time due to the holiday shipping volume.

Scheduled Library Systems Outage Dec. 30, 2020 - Jan. 4, 2021


Due to power maintenance work in Bobst, library systems are expected to be offline from 8:00 pm December 30, 2020 through the day on Monday January 4, 2021. This outage will impact the following online systems:

• library catalog (BobCat)
• book and scan requests
• e-journals
• databases and ebooks
• E-ZBorrow
• Interlibrary loan (ILL)

Read full outage details.
Posted Dec 14, 2020 - 11:09 EST