NYU-NYC Libraries Weather Closures 3/7/18
Incident Report for Public
Resolved
This incident has been resolved.
Posted Mar 08, 2018 - 00:01 EST
Update
All NYU-NYC Libraries' buildings and services will resume normal hours, Thursday, March 8.

For updates about other New York Campus buildings and services see NYU Alerts - https://www.nyu.edu/life/safety-health-wellness/info-alerts.html
Posted Mar 07, 2018 - 22:56 EST
Monitoring
Due to the storm, library services closed at 3 PM today. Bobst Library building will remain open for regular study hours.

All other NYU-NYC Libraries locations are closed. We expect to resume regular hours tomorrow.

For online assistance contact, Ask a Librarian - https://library.nyu.edu/ask/. Stay safe and warm!
Posted Mar 07, 2018 - 15:13 EST