BobCat experiencing loading issues
Incident Report for Public
Resolved
This incident has been resolved.
Posted Oct 29, 2019 - 14:23 EDT
Investigating
Some users may be experiencing issues loading BobCat.

Our teams are working to identify the root cause and implement a solution.

We will post an updated on this page.
Posted Oct 04, 2019 - 08:57 EDT
This incident affected: BobCat (Books & More, Course Reserves) and BobCat Standard.