As of March 14, NYU Libraries services are all online. Library spaces are closed until further notice.
Incident Report for Public
Update
Library services have moved online, spaces are closed until further notice as of Saturday, March 14, 2020

All library services which can be supported remotely will now be offered online only. In-person services are suspended until further notice.

Library spaces on the New York campus are closed.

Loans Extended Until September 8, Fines Waived
All due dates for NYU Libraries materials, ILL, or E-ZBorrow loans are extended until September 8th. Includes Bobst, AFC, Brause, Courant, Dibner, IFA, and ISAW materials.
Check our blog post for full details.

e-Resources
Learn more about our e-resources and online services visit our Remote Library Services page.

University Updates
For updates from the university visit the NYU Coronavirus (COVID-19) Information and Resources page.

#buildingclosure
Posted Apr 03, 2020 - 15:45 EDT
Update
Library services have moved online, spaces are closed until further notice as of Saturday, March 14, 2020

All library services which can be supported remotely will now be offered online only. In-person services are suspended until further notice.

Library spaces on the New York campus are closed.

Learn more about our e-resources and online services visit our Remote Library Services page.

For updates from the university visit the NYU Coronavirus (COVID-19) Information and Resources page.

#buildingclosure
Posted Mar 13, 2020 - 18:01 EDT
Identified
Building access restricted starting the morning of Weds. March 11, 2020

Due to University decisions regarding visitors to NYU, and the need for social distancing during the COVID-19 disruption, we are limiting physical access to all NYU Libraries to current NYU students, faculty, and staff only.

Access will be restricted starting the morning of March 11 until at least the end of March. The Library Privileges desk will be closed.

We are not able to allow access for Consortium members, MaRLI members, Friends of Bobst, Columbia, and all other non-NYU cardholders. If these users need access to our collections, please suggest they place a request through their affiliated interlibrary loan service.

All in-person events are canceled until April 10.

Please visit NYU's Coronavirus (COVID-19) Information page for university updates.

Visit the Libraries' Remote Services page for e-resources and online services.

#scheduledmaintenance
Posted Mar 10, 2020 - 17:59 EDT