NYU-NY: Bobst Library - The building and in person services will be closed from Thursday, June 5th at 11 P.M. until Saturday, June 7th at 7 A.M.

Incident Report for Public

Resolved

This incident has been resolved.
Posted Jun 07, 2025 - 15:21 EDT

Identified

Due to renovation construction Bobst Library will be closed from Thursday, June 5th at 11 P.M. until Saturday, June 7th at 7 A.M.



Bobst in-person services will be closed Friday, and resume at their regularly scheduled Saturday hours.




#buildingclosure
Posted Jun 02, 2025 - 14:00 EDT