NYU New York Libraries are closed Dec. 23, 2023 - Jan. 2, 2024. For details about winter break service changes and catalog updates coming in January,
Incident Report for Public
Resolved
This incident has been resolved.
Posted Jan 03, 2024 - 09:10 EST
Monitoring

NYU New York Winter Break Building and Service Changes, January Catalog Update


All NYU New York Libraries are closed December 23, 2023 through January 2, 2024.


Due Dates and Returns

  • Due dates for regular items are pushed to January (excludes tech loans and reserves materials)
  • Items returned the last week of the semester may still show up as “checked out” in your account until January. These are not considered overdue, and the Libraries will not send overdue messages.
    • Accounts will be updated when the Libraries reopens in January

  • Book drop bins will be available if you wish to return items over winter break but items will not be checked in until staff return from break.

Catalog Updates Coming in January

This fall the Libraries has been working on a system migration project to better support our online catalog and the materials we can offer our users. The migration will be complete in early January and released on January 8th, 2024.

Here’s What to Expect

The catalog interface will look and feel very similar but will include a few big updates & features:
  • A large percentage of articles NYU subscribes to will now be findable in the catalog. You'll be able to search for books, journals, articles, and more in one location.
    • The EBSCO Discovery (EDS) article search tool on the Articles & Databases page will be retired in summer 2024.
  • Saved items will be managed directly in the catalog system. No more having to go to the external eShelf tool.
  • Streamlined requesting process. Make Interlibrary Loan and EZBorrow book requests from within the catalog for items that aren’t available at NYU.
  • We’ll be moving away from the “BobCat” branding for the catalog.

Behind the Scenes

The tools we use behind the scenes will be all new and will help our staff better manage our millions of items.


#buildingclosure
#bobcatmigration
Posted Dec 23, 2023 - 10:42 EST