NYU-NY Bobst & Dibner Libraries: Friday Sept. 29 - Due to weather issues, staffed services and service desks will close at 3:00pm. The buildings will remain open. Services are expected to resume tomorrow at the normally scheduled time.
Incident Report for Public
Resolved
This incident has been resolved.
Posted Oct 01, 2023 - 21:39 EDT
Investigating

Due to weather issues, Bobst and Dibner staffed services and service desks will close early at 3:00 pm on Friday, September 29.


  • Bobst and Dibner buildings will remain open for regular hours

  • Services will close early, but are expected to resume at their normally scheduled time on Saturday, September 30

For virtual help, contact Ask A Librarian (https://library.nyu.edu/ask/).




#weatherclosure
Posted Sep 29, 2023 - 12:52 EDT