Bobst in-person access is currently available to NYU card holders only.
Incident Report for Public
Resolved
Regular library access policies have resumed, please see our Visitors and Members of Libraries-Affiliated Programs page for details when planning your visit.
Posted Jan 10, 2025 - 16:13 EST
Monitoring
Bobst in-person access is currently available to NYU card holders only. Special Collections researchers must have an appointment and be escorted by an NYU Libraries staff member.

#buildingclosure
Posted Jan 08, 2025 - 16:45 EST