Interlibrary Loan (ILL) and "My Requests" electronic documents currently unavailable.
Incident Report for Public
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 10:36 EST
Monitoring
Our teams have implemented a solution and are monitoring the system.
Posted Jan 12, 2021 - 11:00 EST
Investigating
Users may see "File Not Found" under the Documents Available to Save/Print section of the My Requests page instead of the usual link for accessing articles and chapters delivered electronically.

Our teams are investigating the issue.
Posted Jan 12, 2021 - 10:52 EST
This incident affected: E-Shelf and Interlibrary Loan (ILL).