NYU-NY Dibner Library - Hours Update: Fri. March 17th Dibner Library will open at 12pm, the Service Desk will be closed for the full day due to urgent University maintenance work.
Incident Report for Public
Resolved
This incident has been resolved.
Posted Mar 17, 2023 - 22:01 EDT
Identified
#buildingclosure
Posted Mar 17, 2023 - 12:06 EDT
Investigating
In order to perform urgent repairs in 5 MetroTech, there is a scheduled water shutdown between 9:00 AM - 12:00 PM on Friday, March 17. Due to this work, Dibner Library will have a delayed opening to 12:00 PM and the service desk will be closed for the full day.

Regularly scheduled building and service hours will resume on Saturday, March 18.

#buildingclosure
Posted Mar 16, 2023 - 13:52 EDT