New for 2024! Catalog Updates & Temporary Borrowing and Requesting Service Changes.
Incident Report for Public
Monitoring

Library Catalog Updates Released in January


This past fall the Libraries has been working on a system migration project to better support our online catalog and the materials we can offer our users.

The migration was be completed in early January and released on January 8th, 2024.

Here’s What to Expect

The catalog interface will look and feel very similar but will include a few big updates & features:
  • A large percentage of articles NYU subscribes to will now be findable in the catalog. You'll be able to search for books, journals, articles, and more in one location.
    • The EBSCO Discovery (EDS) article search tool on the Articles & Databases page will be retired in summer 2024.

  • Saved items will be managed directly in the catalog system. No more having to go to the external eShelf tool.
  • Streamlined requesting process. Make Interlibrary Loan and EZBorrow book requests from within the catalog for items that aren’t available at NYU.
  • We’ll be moving away from the “BobCat” branding for the catalog.

Behind the Scenes

The tools we use behind the scenes will be all new and will help our staff better manage our millions of items.

Temporary Borrowing and Requesting Changes

During January and February there changes to to borrowing and requesting services for NYUNY, NYUAD, NYUSH.



#bobcatmigration
#scheduledmaintenance
Posted Jan 18, 2024 - 17:46 EST
Identified
#bobcatmigration
#scheduledmaintenance
Posted Jan 01, 2024 - 13:54 EST
This incident affects: Library.nyu.edu (NYU Libraries Website), Library Catalog (Catalog Search, Course Reserves), GetIt (Journals, Record detail page), The Arch (Articles & Databases), Interlibrary Loan (ILL), and EZBorrow.