NYUNY - Bobst First Floor Renovation Project: Service Desk Hours open at 12PM, Oct. 9-10
The renovation of Bobst’s first floor is nearing completion! The service desk will open at 12PM tomorrow, 10/8 and 10/9 and will close at regular hours.
Sign up for our newsletter LibLink for updates and information about upcoming engagements and for updates and chances to tell us what you think.
#scheduledmaintenance
Posted Oct 09, 2025 - 11:58 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 09, 2025 - 11:54 EDT
Identified
NYUNY - Bobst First Floor Renovation Project: Service Desk Hours 12PM-8PM, Oct. 9-10
The renovation of Bobst’s first floor is nearing completion! The service desk will open at 12PM tomorrow, 10/8 instead of 9AM and will close at 8PM as expected.
Sign up for our newsletter LibLink for updates and information about upcoming engagements and for updates and chances to tell us what you think.