Fall 2022 Welcome! What to know about using NYU Libraries this semester.
Incident Report for Public
Resolved
This incident has been resolved.
Posted Sep 23, 2022 - 11:31 EDT
Monitoring

Fall 2022 Welcome!

We're looking forward to supporting you in your learning, teaching, and work this year!

What to Know About Using NYU Libraries this Semester

The Libraries' spaces and services may be a little different this Fall from previous semesters.

Visit Using the Libraries section of our website for key updates about:
  • Building and collection access for the NYU community and visitors
  • Using library spaces
  • Hours of operation
  • Accessibility services

If you're new, or just want a refresher, get the semester started with these key library resources:

  • Ask a Librarian - Chat with a real librarian and get your questions answered anytime.
  • Library Workshops - Sign up to get a head start learning to use library resources and tools!
  • Reservable Study Rooms - We have a reservable spaces for group and individual work to help you make the most of your study time.
  • Rooms & Spaces Directory - find study and productivity spots in Bobst, Brause, and Dibner libraries.

Sign Up for Our Mailing List!

The LibLink mailing list is best way to learn about new resources, events, and more.

What to know more?

Check out our Welcome Research Guide. It's packed with library info, Spotify playlists, wellness resources, and more.

Wishing everyone a great start to the new year!



#nyureturns
Posted Aug 30, 2022 - 17:00 EDT