NYUNY - Bobst First Floor Renovation Project: construction related space impacts in the atrium Oct. 5 - Oct. 16.
Incident Report for Public
Resolved
This incident has been resolved.
Posted Oct 17, 2023 - 10:26 EDT
Update

NYUNY - Bobst First Floor Renovation Project: construction related space impacts in the atrium Oct. 5 - Oct. 16.


The renovation of Bobst’s first floor is nearing completion! During the final phase, carpet and furniture will be installed which will disrupt traffic flow. All library services will operate as usual.
  • Starting Friday, October 13 furniture will be installed in the atrium.
  • Over the weekend of October 14-15, the construction barriers will be removed and the final pieces of furniture will be installed in the gallery and south study space.
  • Throughout Monday, October 16 the entire space will be cleaned.
  • Please allow ample space for installers and cleaning crews to work during this final stage.

The entire first floor will be available for use on Tuesday, October 17.

Other Service and Space Updates:

  • Stair Access: Stairs to and from the Mezzanine level are closed until further notice. Please use the elevators.
  • Study spaces: First floor (gallery and south area), and the mezzanine are unavailable until mid-October.
  • Public computers previously located in the south study space unavailable until late fall 2023.
  • Lockers are relocated to LL2 North hallway, next to the north side stairs that access the lower levels until late fall 2023.


Sign up for our newsletter LibLink for updates and information about upcoming engagements and for updates and chances to tell us what you think.




#scheduledmaintenance
Posted Oct 04, 2023 - 22:12 EDT
Identified

Bobst First Floor Renovation Project: construction related noise alerts; and space and service impacts.


Bobst’s first floor is undergoing exciting changes this fall. Read more about how we’re reimagining Bobst’s first floor.

While improvements are made to the building, the services and spaces may be impacted. We will update this page as the project progresses. Please note timelines are subject to change.


Construction Noise Alerts:

Drilling work will take place Saturdays and Sundays through September.

  • The noise is expected to be loud in the first floor atrium and on the balconies.
  • Nose may be audible in other areas of the library.

HVAC work 7am-3pm, Mon. Sept. 18 through Sun. Sept. 25

  • Maintenance work will be done on the HVAC vents at the base of the exterior windows and may involve some noise from work and machinery.
  • Work will start on 9 west and continue on floors 9, 8, 7, 6, 5 throughout the week.

We appreciate your patience and hope to minimize the disruption as much as possible given the extent of the construction work.

Service and Space Updates:

  • Stair Access: Stairs to and from the Mezzanine level are closed until further notice. Please use the elevators.
  • Study spaces:
    • First floor (gallery and south area), and the mezzanine are unavailable until mid-October.
    • LL1 Study rooms: the following rooms will be unavailable on the weekends through September:
      • LL1-09A
      • LL1-09B
      • LL1-10
      • LL1-18
  • Public computers previously located in the south study space unavailable until late fall 2023.
  • Lockers are relocated to LL2 North hallway, next to the north side stairs that access the lower levels until late fall 2023.

Sign up for our newsletter LibLink for updates and information about upcoming engagements and for updates and chances to tell us what you think.




#scheduledmaintenance
Posted Sep 20, 2023 - 10:49 EDT