NYU-NY: All Library buildings and services will closed May 20-21. For any online catalog issues...
Incident Report for Public
Resolved
This incident has been resolved.
Posted May 22, 2023 - 00:00 EDT
Monitoring

All NYUNY library buildings and services will be closed Saturday, May 20th through Sunday, May 21st.



If you are experiencing any catalog loading issues or errors:


If you get the "search failed due to a system error" message when trying to search for an item in the catalog, as a temporary workaround give the system a moment and try reloading the page.

You can report other issues via Online Catalog Feedback Form and our teams will be able to investigate when the Libraries offices reopen on Monday, May 22nd.

We wish everyone a great start to the summer, and congratulations to all the 2023 NYU graduates!




#buildingclosure
Posted May 18, 2023 - 16:07 EDT