Archival Collections search portal is experiencing intermittent outages
Incident Report for Public
Resolved
This incident has been resolved.
Posted Feb 08, 2020 - 09:30 EST
Identified
The Archival Collections search portal (i.e. https://specialcollections.library.nyu.edu) is experiencing slowdowns and intermittent outages. We are working on a solution and will provide updates as we have them.

Sorry for the inconvenience.
Posted Feb 07, 2020 - 21:16 EST
This incident affected: Archival Collections.