NYU Returns: What to know about using NYU Libraries for Fall
Incident Report for Public
Identified

What to know about using NYU Libraries for Fall 2020.


Updated October 8, 2020

Using the NYU Libraries will be a bit different this fall.
If you’re joining us on the NYC campus, or remotely this fall, our staff is committed to supporting your research, teaching, and learning needs remotely.


Libraries' NYU Returns page to be up-to-date on the latest information about our services, collections, spaces, and safety.

Building Access and Hours for Fall 2020
Bobst and Dibner Libraries (updated October 8, 2020):
Weekday Hours: Open Monday to Friday, 7:30 am to 9:30 pm for the following services:
- contactless pickup of physical items
- classroom use
- appointments
- reservable remote learning and study space

Weekend Hours: Open Saturday and Sunday, 10:00 am to 7:00 pm for reservable remote learning and study spaces on the following floors.
- Bobst: Lower Level 1 (LL1), and 1st Floor
- Dibner: 3rd Floor spaces are now reservable


For detailed online and on-site building and service hours, please visit our Hours page.

• Entrance to libraries is restricted to NYU cardholders with an appropriate face covering and a valid COVID-19 daily screener. No visitors will be granted access to library buildings.


Using Library Collections

• Physical library collections are closed to direct access and browsing. For more information about accessing physical library collections, please visit the Collections Access page.


• All digital collections, over 3 million items, remain available via the NYU Libraries website. The HathiTrust service will continue, providing digital access to 40 percent of the print collection.


• Physical items may be ordered online and accessed via contactless pickup, delivery, or scanning. Visit the Delivery Service Options for Material Not Available Electronically information on our Collections Access page.

Loans Extended Until October 15, Fines Waived

- All due dates for NYU Libraries materials, ILL, or E-ZBorrow loans are extended until October 15th.
- Includes Bobst, AFC, Brause, Courant, Dibner, IFA, and ISAW materials.


Student & Faculty Services
Please note, for promptest assistance from specific service points please email, rather than call.

• Reference, research consultations are available as remote services


Accessibility Services, and Special Collections will offer remote services as well as limited appointment-based onsite services.


Course Reserves services are entirely digital.


• Onsite printing and scanning services are unavailable at Bobst and Dibner Libraries. Visit NYU ITs Print Service page for information on modified locations, policies and hours of operations for printing and scanning services.


If you have questions or need help use our Ask a Librarian chat and email service.


#buildingclosure
Posted Nov 12, 2020 - 11:05 EST