BobCat experiencing loading issues
Incident Report for Public
Resolved
The issue has been resolved.
Posted about 1 month ago. Aug 07, 2019 - 10:37 EDT
Investigating
Some users may be experiencing issues loading BobCat.

Our teams are working to identify the root cause and implement a solution.

We will send additional updates as we receive them.
Posted about 1 month ago. Aug 06, 2019 - 19:46 EDT
This incident affected: BobCat (Books & More, Course Reserves) and BobCat Standard.