NYU Returns: What to know about using NYU Libraries for Summer 2021.
Incident Report for Public
Resolved
Please visit library.nyu.edu for information about using NYU Libraries for Fall 2021.
Posted Sep 01, 2021 - 22:02 EDT
Identified

What to know about using NYU Libraries for Summer 2021. Updated: June 2, 2021



If you’re joining us on the NYC campus, or remotely this spring, our staff is committed to supporting your research, teaching, and learning needs remotely.

Libraries' NYU Returns page to be up-to-date on the latest information about our services, collections, spaces, and safety.

Building Access and Hours for Summer 2021


Bobst and Dibner Libraries will be open for the following services:
• contactless pickup and return of physical items
• classroom use
• walk-in and reservable remote learning and study space via Scan & Request in the NYU Mobile app.

For detailed online and on-site building and service hours, please visit our Hours page.

• Entrance to libraries is restricted to NYU cardholders with an appropriate face covering and a valid COVID-19 daily screener. No visitors will be granted access to library buildings.


Using Library Collections


• Physical library collections are closed to direct access and browsing. For more information about accessing physical library collections, please visit the Collections Access page.


• All digital collections, over 3 million items, remain available via the NYU Libraries website. The HathiTrust service will continue, providing digital access to 40 percent of the print collection.


• Physical items may be ordered online and accessed via contactless pickup, delivery, or scanning. Interlibrary Loan and E-ZBorrow services have resumed, although delivery turnaround may be delayed. Visit the Delivery Service Options for Material Not Available Electronically information on our Collections Access page.

Student & Faculty Services


• Reference and research consultations are available as remote services


Accessibility Services, and Special Collections will offer remote services.


Course Reserves services are entirely digital.


• Printing and onsite scanning services are not available at Bobst and Dibner libraries. Visit NYU IT Print Service page for information on modified locations, policies and hours of operations for printing and scanning services.


If you have questions or need help use our Ask a Librarian chat and email service.



Get a preview of what to expect for fall 2021.



#buildingclosure
Posted Jun 02, 2021 - 00:00 EDT