Bobst Library Emergency Repairs: Bathrooms on West Side Closed 10/24/2023
Incident Report for Public
Resolved
The bathroom maintenance has been completed. All bathrooms are open again in Bobst Library.
Posted Oct 25, 2023 - 14:06 EDT
Identified
Bobst Library needs to undergo emergency repairs on a leaking pipe on the 2nd floor West side of the Library tonight (10/24/23) at 9:00pm. Until the repairs are finished, all bathrooms on the West Side of Bobst Library from the 2nd floor up to the 12th floor will be closed . Please use the bathrooms on the East Side of the building during this time. Signs will be posted on the closed bathrooms as well. Updates will be provided if closures stay in place tomorrow.

#majoroutage
Posted Oct 24, 2023 - 13:02 EDT