Archival Collections/Special Collections Search issues loading search results, and intermittent outages. Use the library catalog to search and access finding aids.

Incident Report for Public

Monitoring

After our teams have identified the issues and applied temporary fixes. The team will continue to monitor the system for intermittent outages.

Posted Jun 10, 2025 - 12:03 EDT

Investigating

The Archival Collections/Special Collections site (specialcollections.library.nyu.edu) is experiencing issues loading search results and may have intermittent outages.


Recommended Workaround:

Use the library catalog scoped to "Special Collections" to access finding aids.

We are working diligently to restore service as soon as possible, and apologize for the inconvenience.




#majoroutage
Posted Jun 10, 2025 - 10:38 EDT

Monitoring

Archival Collections/Special Collections Search issues are resolved, pease report any issues you notice.
Posted Jun 02, 2025 - 13:59 EDT

Identified

The Archival Search/Special Collections search is experiencing intermittent outages.

Our teams are working on a solution.

Recommended Workaround:

Use the library catalog scoped to "Special Collections" to access finding aids.

#majoroutage
Posted May 29, 2025 - 14:54 EDT

Monitoring

After our teams have identified the issues and applied temporary fixes. The team will continue to monitor the system for intermittent outages.
Posted May 27, 2025 - 16:18 EDT

Investigating

The Archival Collections/Special Collections site (specialcollections.library.nyu.edu) is experiencing issues loading search results and may have intermittent outages.


Recommended Workaround:

Use the library catalog scoped to "Special Collections" to access finding aids.

We are working diligently to restore service as soon as possible, and apologize for the inconvenience.

Posted May 27, 2025 - 12:30 EDT
This incident affects: Archival Collections.