NYU-NY Tuesday, February 24: Bobst library circulation desk will open at 12pm, all other library buildings and services are operating on their regular hours.

Incident Report for Public

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 09:44 EST

Identified

Tuesday, February 24 in-person service adjustment for Bobst Library


  • Bobst Library circulation desk will open at 12pm.
  • Other in-person services are operating on their regular hours.
  • Study spaces in Bobst and Dibner libraries are open.


Visit our hours page for regular open hours for specific libraries and services.

#weatherclosure
Posted Feb 24, 2026 - 09:28 EST

Monitoring

On Tuesday, February 24, library buildings and services will have regular hours of operation.

#weatherclosure
Posted Feb 23, 2026 - 21:11 EST

Identified

Due to the winter storm, all in-person library services will be closed on Sunday, February 22 and Monday February 23.



For weather-related updates about other non-library campus services and spaces visit NYU's Alert page .





#weatherclosure
Posted Feb 22, 2026 - 14:00 EST