e-Shelf's "My Library Account" tabs not loading in Chrome
Incident Report for Public
Resolved
This incident has been resolved.
Posted Jan 06, 2021 - 14:26 EST
Monitoring
To access your account use the "trouble loading" link, or a different browser such as Safari or Firefox. We are monitoring the results of this temporary fix.
Posted Dec 24, 2020 - 10:33 EST
Investigating

Chrome users may find no data loads for the tabs in the e-Shelf "My Library Account":


Tabs affected:
- Loans
- Holds
- Bookings
- Fines/Fees

Our team is investigating the issue. To access your account use the "trouble loading" link, or a different browser such as Safari or Firefox.
Posted Dec 17, 2020 - 23:45 EST
This incident affected: E-Shelf.