NYU Returns NYU-NY: Dec. 16 -22, Library buildings open, virtual service available.
Incident Report for Public
Resolved
This incident has been resolved.
Posted Jan 03, 2022 - 23:55 EST
Investigating

December 16, 2021 - December 22, 2021 NYU-NY Library services are offered virtually, buildings are open.


In response to the University's updated safety protocols the Libraries has changed some services through the end of the semester.

Buildings and Spaces Changes:

  • Bobst and Dibner buildings, including stacks, are open 24hrs.
  • Group study study rooms are closed at all library locations
  • Wednesday, January 22, 2021 is the last day for visitor access.

Service Changes:

Services are available virtually during regular hours, unless noted otherwise.

  • Reference Services are available on Ask-A-Librarian chat, email, and text.
  • Client Services
    • The Bobst Library Computer Center (BLCC) is open for returns only until 5:00 PM on Friday, December 17.
      • No new loans will be made after 10:00 AM on Thursday, December 16.
      • All outstanding loans that have not been returned by 5:00 PM Friday, December 17 will have their loans extended until the end of January 2022.
    • Helpdesk support is remote starting 5:00 PM on Friday, December 17.
  • Bobst Circulation and Reserve Services are on-demand for course reserves. Students can call 212-998-2475 during regular desk hours for assistance.
    • Self-checkout is available for stacks items.
    • Locker delivery requests can be made through the close of business on Sunday, December 19. Requests made after this deadline will be fulfilled in the new year. Locker pickup is available anytime the building is open.
  • The Dibner Library service desk is closed to in-person service. On-demand circulation will be available through the end of the day Thursday, December 16.
    • Users can call 646-997-3530 for course reserve needs through the end of the day Thursday, December 16. All course reserve loans will be given a due date of Thursday, December 23.
    • Locker requests will be processed until close of business on Thursday, December 16.

  • Avery Fisher Center’s desk is closed, but staff will provide on-demand service for course reserves and media materials. Questions can be emailed to afc-admin-group@nyu.edu, which will be monitored throughout the day.
  • Data Services in-person service is closed but help is available virtually. Email data.services@nyu.edu for appointments.
  • Digital Studio walk-in service is closed with only virtual services available. Email digital.studio@nyu.edu for help.
  • Special Collections in-person services are closed. Users should reach out to special.collections@nyu.edu for information about service availability.

  • Important Dates for Requesting Library Materials (2021)

    • We’ll do our best to process delivery requests placed by 5:00 PM (ET) on December 15 before the winter break begins.
    • Requests placed after 5:00 PM on December 15 will be processed in the order received when the library services reopen in January 2022.
    • Bobst locker delivery is the fastest delivery option, please plan to retrieve items by December 22. Bobst pickup will be available December 27-30 but building open hours will be limited.
    • Scan requests will be delivered by December 22.
    • Home delivery may take longer than usual during this time due to the holiday shipping volume.
    • We cannot provide delivery guarantees for Interlibrary Loan (ILL) and EZBorrow requests. It is likely that requests placed after December 10 won't be delivered until January 2022.

    Winter Break Access: December 23, 2021–January 3, 2022

    • NYU Libraries buildings will have limited hours and access during winter break, and reopen on January 3, 2022.
      • There will be no visitor access during this time.
    • Library services will be closed, and reopen with remote service on January 4, 2022.
    • Refer to the hours page for the most up to date information.

    Good luck with finals, and have a restful break!



    #nyureturns
Posted Dec 22, 2021 - 13:46 EST