Some users may be experiencing trouble when logging in to Library online systems and services.
Incident Report for Public
Resolved
Our teams have resolved the issue with login. Services that require login are available.
Posted 10 days ago. Sep 10, 2019 - 12:31 EDT
Investigating
Some users may be experiencing trouble when logging in to online systems and services. Our teams are currently investigating.

We will post an update in the next 30 minutes

#majoroutage
Posted 10 days ago. Sep 10, 2019 - 11:01 EDT
This incident affected: Library.nyu.edu (NYU Libraries Website), Login, E-Shelf, BobCat (Books & More, Course Reserves), GetIt (Journals, Record detail page), The Arch (Articles & Databases), Interlibrary Loan (ILL), Room Reservation System, BobCat Standard, Archival Collections, Privileges Guide, MaRLI (Manhattan Research Library Initiative), E-ZBorrow, and EZProxy.