Snow Alert NYUNY: Library buildings will re-open Weds. Feb. 3. Request services & course reserves may still have significant delays.
Incident Report for Public
Resolved
This incident has been resolved.
Posted Feb 05, 2021 - 11:12 EST
Monitoring

NYU's New York campus will be re-open, Wednesday, February 3, 2021


Library buildings will resume their normal operating hours.


Scanning, home delivery, and course reserves requests may be significantly delayed as our teams work through the backlog of requests that were submitted while the offices were closed. We will process requests as quickly as possible.



Please check the NYU Alerts page for updates and safety information.

Posted Feb 02, 2021 - 23:50 EST
Identified
Posted Feb 02, 2021 - 17:46 EST
Update

Due to ongoing snow NYU's New York campus will be closed again, Tuesday, February 2, 2021


All NYUNY Library buildings will be closed. Remote services and Ask a Librarian will be available.


• Return bins at Bobst and Dibner Libraries remain open 24/7

• Locker pick-up will be unavailable at Bobst and Dibner due to building closures

Scanning, home delivery, and course reserves requests may be significantly delayed. We will process requests as quickly as possible when our staff returns to campus.

• Study and remote learning spaces are closed

Please check the NYU Alerts page for updates and safety information.



#weatherclosure
Posted Feb 01, 2021 - 17:04 EST
Investigating

Due to snow NYU's New York campus will be closed, Monday, February 1, 2021


All NYUNY Library buildings will be closed. Remote services and Ask a Librarian will be available.


• Return bins at Bobst and Dibner Libraries remain open 24/7

• Locker pick-up will be unavailable at Bobst and Dibner due to building closures

• Scanning, home delivery, and course reserves requests may delayed. We will process requests as quickly as possible when our staff returns to campus.

• Study and remote learning spaces are closed

Please check the NYU Alerts page for updates and safety information.

Posted Feb 01, 2021 - 17:02 EST