Library Web Forms are Unavailable
Incident Report for Public
Resolved
It appears the vendor has fixed the issue and web forms are back online.
Posted Jul 22, 2021 - 13:56 EDT
Investigating
Some of the Libraries' online forms used to request library services are currently offline because the vendor (Qualtrics) is experiencing outages.

You may received a DNS failure notice when trying to access these forms:

- Student Course Reserves Requests
- AFC service requests
- Purchase Suggestions
- Library Comments & Suggestions form
- Library Catalog feedback form
- Instruction Request form

We thank you for being patient and recommend trying the service later.

We will report any updates we have when they become available.
Posted Jul 22, 2021 - 12:03 EDT