e-Shelf email feature unavailable
Incident Report for Public
Resolved
Email functionality has been restored.
Posted Nov 12, 2020 - 12:05 EST
Identified
The emailing records feature in e-Shelf currently unavailable. Our teams are working on the issue and will post updates to this page.
Posted Nov 12, 2020 - 11:03 EST
This incident affected: E-Shelf.