Update: Due to construction and repair-related work in Bobst Library, the building will be closed until Saturday January 4th. Due dates for impacted materials have been adjusted.
Incident Report for Public
Resolved
The Bobst Library building is reopening Saturday January 4th at 7am. Building spaces and services will follow regularly scheduled January hours.
Posted Jan 04, 2025 - 00:12 EST
Update
Thurs., Jan. 2 @ 5:00 p.m. ET - Material Due Date Changes

  • All materials from Bobst/Bobst Offsite, AFC/AFC Offsite, and ILL items with due dates impacted by the closure have been extended to be due on Monday, Jan. 6

  • The library does not charge any late fines for Bobst/Bobst Offiste books (including ILL)

  • Return bins will remain available during the closure

  • If users still need assistance, they can reach out directly to lib-circulation@nyu.edu for NYU owned material and lib-ill@nyu.edu for resource sharing items.


#buildingclosure
Posted Jan 02, 2025 - 17:42 EST
Update
Wednesday, Jan. 1 @ 10:00 a.m. ET – Following further evaluation of construction- and repair-related work remaining to be finished, Bobst Library will remain closed through Friday, January 3.

The library is expected to reopen for all regular operations on Saturday, January 4.

Employees who work in the library and who were planning on returning to work in person on Thursday and Friday should instead plan to be in touch with supervisors about working remotely those days.

#buildingclosure
Posted Jan 01, 2025 - 10:40 EST
Identified
Tues, Dec. 31 @ 1:50 p.m. ET – As a result of ongoing efforts to address significant plumbing issues that arose and needed to be repaired this week, Bobst Library will remain closed for an additional day: Thursday, January 2.

The library is expected to reopen for all regular operations on Friday morning, January 3. If the repair work is not completed on Thursday, we will communicate further regarding any additional changes to the library’s schedule.

Employees who work in the library and who were planning on returning to work in person on Thursday should instead plan to be in touch with supervisors about working remotely that day.

#buildingclosure
Posted Dec 31, 2024 - 14:10 EST