Some users may be experiencing trouble when logging in to Library online systems and services.
Incident Report for Public
Postmortem

What happened?

On Wednesday, January 29, our monitoring systems began reporting excessive CPU usage on some of our Kubernetes (K8s) nodes, which are responsible for hosting the single-sign-on Login application (i.e. https://login.library.nyu.edu). While this issue was resolved and did not in itself cause any application outages, the rescheduling of one of the pods used for application caching was no longer discoverable by the Login application. This manifested to users as apparently not being logged in, even when a user had indeed logged in. Because only one of the cache pods couldn’t be found, the behavior was inconsistent.

Posted Feb 03, 2020 - 16:18 EST

Resolved
This incident has been resolved.
Posted Jan 31, 2020 - 10:31 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 30, 2020 - 12:49 EST
Investigating
Some users may be experiencing trouble when logging in to online systems and services. Our teams are currently investigating.

We will send an additional update in 30 minutes.
Posted Jan 30, 2020 - 08:48 EST
This incident affected: Library.nyu.edu (NYU Libraries Website), Login, E-Shelf, BobCat (Books & More, Course Reserves), GetIt (Journals, Record detail page), The Arch (Articles & Databases), Interlibrary Loan (ILL), Room Reservation System, BobCat Standard, Archival Collections, Privileges Guide, MaRLI (Manhattan Research Library Initiative), E-ZBorrow, and EZProxy.