NYUNY - Dec. 1, 2023: Non-NYU visitors are not able to access Bobst Library today. Only those with Special Collections appointments will be allowed entry.
Incident Report for Public
Resolved
This incident has been resolved.
Posted Dec 02, 2023 - 01:08 EST
Identified

Non-NYU visitors are not able to access Bobst Library today. Only those with Special Collections appointments will be allowed entry at this time.



New School and Cooper Union students and faculty will continue to have tap access to Bobst. The access restriction applies to guests of students and faculty, Friends of Bobst, MARLI members, NYSID, alumni, etc.

#scheduledmaintenance
Posted Dec 01, 2023 - 10:12 EST