E-Shelf System Outage, Saved Catalog Items Temporarily Unavailable.
Incident Report for Public
Resolved
This incident has been resolved.
Posted Feb 17, 2023 - 17:19 EST
Monitoring
E-Shelf and related services have been restored.
Our teams will continue to monitor the systems.
Posted Jan 10, 2023 - 12:12 EST
Investigating
The e-Shelf system is currently experiencing an outage. Users may not be able to view their saved catalog items at this time.

Loan information is still available via the My Library Account feature in the library catalog (BobCat).

Our teams are investigating the issue. We will share updates to this page when they're available.

#majoroutage
Posted Jan 10, 2023 - 11:34 EST