NYU Returns: What to know about using NYU Libraries for Spring 2022.
Incident Report for Public
Resolved
This incident has been resolved.
Posted May 31, 2022 - 10:26 EDT
Update
#nyureturns
Posted Apr 22, 2022 - 14:43 EDT
Identified

What to know about using NYU Libraries for Spring 2022


Updated: 3/3/2022
In response to the University's updated safety protocols the Libraries' have adjusted services for the spring semester.

Building & Space Updates:

New! - Construction Alert - Bobst Lower Level 2 (LL2)

NYU's Office of Construction Management will be working on the west side of Lower Level 2. Please be advised there will be construction related noise.
  • Timeline: March 2, 2022 through the end of the spring semester
  • Construction Hours: 8:00 AM - 4:00 PM Monday through Friday
  • Construction Noise Impact: Open spaces and group study rooms on the west side will be most impacted by the noise, but it may be noticeable in all study rooms on LL2.

Report Noise and Other Issues to FCM Client Service Center:


Bobst Stacks, Reading Rooms & Classroom Access

  • LL1, LL2, and Floor 1 study areas open 24/7.
  • Floors 4-9 open regular hours, 7:00 AM to 1:00 AM daily, for stacks, study area, and classroom access.
  • Floor 10 East Asian Reading Room is closed through the spring semester. Make requests for materials from the East Asian collection via the catalog.
Check the hours web page for information about specific dates.

Bobst Reference and Computer Center Services moved on Floor 1

Research & Reference Services, and Computer Services have relocated to the service desk in the atrium (alongside Circulation & Reserves).

Group & Individual Study Rooms

Masks must be worn at all times, even when working alone. Eating is not allowed.
  • Group study rooms in Bobst, Dibner, and Jack Brause Libraries are open.
  • Individual study rooms at Dibner are open. A limited number are also available at Bobst.

Services Updates:

  • Library in-person services are open, check the hours guide for specific services opening and closing times.
  • Liaisons, Data Services, Digital Studio will continue to also offer appointments.
  • Virtual Reference services (AAL) will be available 24/7.
  • Special Collections services will be by appointment only.
Please note that while we will try hard to avoid it, there may be hours changes or service point closures if there are staffing shortages.

Mask & Eating Policies:


Visitors: access is unavailable until further notice.



Please visit the Libraries' NYU Returns page for more details using the Libraries.


Wishing everyone the best for the spring semester!



#nyureturns
Posted Mar 03, 2022 - 10:48 EST