E-Z Borrow Service Offline from Aug. 5th to Aug 16th.
Incident Report for Public
Resolved
The system update is complete.
Posted Aug 16, 2021 - 11:38 EDT
Identified
E-Z Borrow services will be offline from August 5th to August 12th in order to migrate the service onto new platform, Project ReShare. In the meantime, please use Inter-Library Loan to put in requests for materials unavailable at NYU, or wait until after August 12th to resume using E-Z Borrow.
Posted Aug 05, 2021 - 09:45 EDT
This incident affected: E-ZBorrow.