Some users may be experiencing trouble when logging in to Library online systems and services.
Incident Report for Public
Resolved
The storage optimization process on the login database is now complete. The incident has been resolved.
Posted Feb 20, 2020 - 13:11 EST
Monitoring
Users should now be able to successfully connect to our systems and services using the login page.

The full implementation of the solution may take up to 24 hours, so we’ll be monitoring the service during that time.
Posted Feb 20, 2020 - 12:51 EST
Identified
Our teams have identified the issue and are working to resolve the login issues.

We'll continue to post updates to this page.

#majoroutage
Posted Feb 20, 2020 - 11:31 EST
Investigating
Some users may be experiencing trouble when logging in to online systems and services. Our teams are currently investigating.

We will send an additional update in 30 minutes.

#majoroutage
Posted Feb 20, 2020 - 10:54 EST