NYU-NY Libraries Weather Closure 03/21/2018
Incident Report for Public
Resolved
This incident has been resolved.
Posted about 1 year ago. Mar 22, 2018 - 02:17 EDT
Update
NYU's New York campus is scheduled to resume normal operations tomorrow, Thursday, March 22, 2018.

NOTE: The University is monitoring weather developments carefully and will communicate updates via NYU Alerts http://nyu.edu/alerts.
Posted about 1 year ago. Mar 21, 2018 - 19:05 EDT
Monitoring
Due to snow, NYU-NY Libraries system will be closed on Wednesday, March 21, 2018.

Bobst Library — Lower Levels 1 & 2 will remain open 24 hours for study. Bobst services, and spaces on other floors, including reserved study rooms, will be closed.

All other NYU-NY library buildings will be closed (Brause, Courant, Dibner, IFA, ISAW).

For virtual help, contact Ask A Librarian (https://library.nyu.edu/ask/).

See NYU Alerts for University updates for NYU-NY campus closures http://nyu.edu/alerts
Posted about 1 year ago. Mar 20, 2018 - 18:31 EDT