Interlibrary Loan Outage
Incident Report for Public
Resolved
The systems have been restarted and service are fully restored.
Posted about 1 year ago. Mar 31, 2018 - 12:27 EDT
Investigating
ILL is experiencing temporary system outages, we're working to restore services. Please check back later to see if services have been restored. We apologize for the inconvenience.
Posted about 1 year ago. Mar 31, 2018 - 11:01 EDT