Bobst Library Wifi Outage
Incident Report for Public
Resolved
WiFi service for Bobst Library has been restored.
Posted about 1 year ago. Mar 09, 2018 - 13:24 EST
Investigating
WiFi is currently down in Bobst Library for some users. The issue is being investigated.

We apologize for the inconvenience and will let you know when service is restored.
Posted about 1 year ago. Mar 09, 2018 - 13:03 EST