All Systems Operational

About This Site

Real-time information about library system outages, service updates and planned maintenance

This site is available via the "Status Page" link in the footer of the library.nyu.edu website.

Library.nyu.edu (NYU Libraries Website) Operational
Library Catalog (Catalog Search, Course Reserves) Operational
GetIt (Journals, Record detail page) Operational
The Arch (Articles & Databases) ? Operational
Interlibrary Loan (ILL) Operational
Room Reservation System Operational
Archival Collections Operational
MaRLI (Manhattan Research Library Initiative) ? Operational
EZBorrow Operational
EZProxy Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Past Incidents
Mar 28, 2024

No incidents reported today.

Mar 27, 2024

No incidents reported.

Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024
Completed - The scheduled maintenance has been completed.
Mar 24, 00:00 EDT
Update -

Update: Bobst Library early closing scheduled on Friday, March 22 is cancelled.

  • Floors 4-10 will be open until 1:00 am
  • Floor 1, and Lower Levels 1 (LL1) and 2 (LL2) are open 24hrs.



#scheduledmaintenance

Mar 22, 02:09 EDT
Scheduled -

Sunday March 22 - Saturday March 23
Bobst building maintenance work, Bobst and Dibner Libraries adjusted service hours.


Service Hours Changes
Monday March 18 - Friday March 22:


Bobst Building Maintenance
Sunday March 17 - Friday March 22:


The following building work hours will be between 7am to 4pm:

  • First Floor Lighting: Additional track lighting heads will be installed along the outside wall of the gallery. This requires a genie lift, and the gallery will be closed during the work.
  • Outlet Repair and Replacement: Sections of Lower Level 1, Floor 2 North Reading Room, and Floor 6 will be closed to repair/replace electrical outlets built into the furniture.
  • Floor 11 Renovation Work: There may be noise disturbances related to the work.

The Bobst Building Early Closure:
Friday March 22 at 10pm, reopens at 7:00am Saturday March 23.


Normal hours for all locations will resume Saturday, March 23

Check our hours page for specific locations' weekend building and services hours.

Happy Spring Break!



#scheduledmaintenance

Mar 15, 23:07 EDT
Mar 23, 2024

No incidents reported.

Mar 22, 2024

No incidents reported.

Mar 21, 2024

No incidents reported.

Mar 20, 2024

No incidents reported.

Mar 19, 2024

No incidents reported.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024

No incidents reported.

Mar 14, 2024

No incidents reported.